Liferay Portal Uses Default PasswordGHSA-43xf-59vr-g4f2
GHSA-43xf-59vr-g4f2 is a CWE-1393 vulnerability in com.liferay.portal:release.portal.bom. A fix is available for com.liferay.portal:release.portal.bom — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-43xf-59vr-g4f2.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
com.liferay.portal:release.portal.bomReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Liferay Portal 7.4.0 through 7.4.3.111, and older unsupported versions, and Liferay DXP 2023.Q4.0, 2023.Q3.1 through 2023.Q3.4, 7.4 GA through update 92 and 7.3 GA through update 35, and older unsupported versions does not limit access to APIs before a user has changed their initial password, which allows remote users to access and edit content via the API.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.liferay.portal:release.portal.bom | ≥ 7.4.0&&< 7.4.3.112 | 7.4.3.112com.liferay.portal:release.portal.bom:7.4.3.112 |
Affected Products
digital experience platformliferayliferay portalliferayDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.liferay.portal:release.portal.bom, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.liferay.portal:release.portal.bom to 7.4.3.112 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-43xf-59vr-g4f2 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-43xf-59vr-g4f2 in your dependencies?
Find it across Maven, including transitive dependencies.