cannot be blank.\"],\"slug\":[\"Slug cannot "}},{"@type":"Question","name":"How severe is GHSA-3wxg-w96j-8hq9?","acceptedAnswer":{"@type":"Answer","text":"GHSA-3wxg-w96j-8hq9 has a CVSS score of 3.7/10, rated LOW. Review your exposure and patch according to your risk tolerance."}},{"@type":"Question","name":"Which packages are affected by GHSA-3wxg-w96j-8hq9?","acceptedAnswer":{"@type":"Answer","text":"GHSA-3wxg-w96j-8hq9 affects the following packages: craftcms/cms (Packagist), craftcms/cms (Packagist). Ecosystems affected: Packagist."}},{"@type":"Question","name":"How do I fix GHSA-3wxg-w96j-8hq9?","acceptedAnswer":{"@type":"Answer","text":"Update craftcms/cms to 4.4.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-3wxg-w96j-8hq9 is resolved across your whole dependency graph."}},{"@type":"Question","name":"How do I detect GHSA-3wxg-w96j-8hq9 in my Packagist dependencies?","acceptedAnswer":{"@type":"Answer","text":"Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for craftcms/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version."}},{"@type":"Question","name":"How do I mitigate GHSA-3wxg-w96j-8hq9 if there is no patch (or I can't update yet)?","acceptedAnswer":{"@type":"Answer","text":"Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page."}},{"@type":"Question","name":"Is GHSA-3wxg-w96j-8hq9 actively exploited in the wild?","acceptedAnswer":{"@type":"Answer","text":"Yes. There are 1 known exploit references for GHSA-3wxg-w96j-8hq9, including 1 in-the-wild exploitation observed on GitHub and other sources. Treat this as actively exploitable and prioritize patching immediately. All exploit code should only be run in an isolated sandbox environment for research or authorized testing — never against production systems without explicit written authorization."}},{"@type":"Question","name":"What is the EPSS score for GHSA-3wxg-w96j-8hq9?","acceptedAnswer":{"@type":"Answer","text":"GHSA-3wxg-w96j-8hq9 has an EPSS (Exploit Prediction Scoring System) score of 0.6%, placing it in the 50th percentile of all CVEs. EPSS is maintained by FIRST.org and estimates the probability that a vulnerability will be exploited in the wild within the next 30 days. This score indicates relatively lower exploitation probability, though the CVSS severity should still guide your patching priority."}},{"@type":"Question","name":"What type of vulnerability is GHSA-3wxg-w96j-8hq9?","acceptedAnswer":{"@type":"Answer","text":"GHSA-3wxg-w96j-8hq9 is classified as CWE-80 (CWE-80), Cross-site Scripting (XSS) (CWE-79). These weakness types describe the underlying flaw category, which helps determine the potential impact and the right class of mitigation. This is a high-impact weakness class that often enables remote code execution or data exposure."}},{"@type":"Question","name":"When was GHSA-3wxg-w96j-8hq9 published, and has it been updated?","acceptedAnswer":{"@type":"Answer","text":"GHSA-3wxg-w96j-8hq9 was published on May 26, 2023 and was last updated on September 10, 2026. Advisory data evolves as severity scores, affected ranges, and exploit intelligence are revised — always check the latest version of the advisory before acting."}}]}
NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
LOW severity

CraftCMS stored XSS in Quick Post widget error messageGHSA-3wxg-w96j-8hq9

LOWFix: craftcms/cms@9d0cd0b

GHSA-3wxg-w96j-8hq9 is a low-severity (CVSS 3.7) CWE-80 vulnerability in craftcms/cms. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for craftcms/cms — see the affected versions and patch details below.

Also known asCVE-2023-33194
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-3wxg-w96j-8hq9.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs50th percentile — riskier than 50% of all scored CVEsHighest risk
0.00%0.37%0.74%1.12%0.1%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘craftcms/cms🐘craftcms/cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Summary

The platform does not filter input and encode output in Quick Post validation error message, which can deliver an XSS payload.

Details

Old CVE fixed the XSS in label HTML but didn’t fix it when clicking save.

PoC

  1. Login at admin

  2. Go to setting

  3. Create a Section

  4. On Entry page, click Edit label

  5. Inject the XSS payload into the label and save

  6. On the admin dashboard choose new widget -> Quick Post

  7. In Quick Post, click save with blank slug; The XSS will be executed

    "errors":{"title":["<script>alert('nono')</script> cannot be blank."],"slug":["Slug cannot be blank."]

Fixed in https://github.com/craftcms/cms/commit/9d0cd0bda7c8a830a3373f8c0f06943e519ac888

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcraftcms/cms≥ 4.0.0-RC1&&< 4.4.64.4.6composer require craftcms/cms:^4.4.6
🐘Packagistcraftcms/cms≥ 3.0.0&&< 3.8.63.8.6composer require craftcms/cms:^3.8.6

Affected Products

2 products · 6 configurations
Application
craft cmscraftcms
≥ 4.0.1 && < 4.4.6
range
Application
craftercmscraftercms
1 version
4.0.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for craftcms/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update craftcms/cms to 4.4.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-3wxg-w96j-8hq9 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Summary The platform does not filter input and encode output in Quick Post validation error message, which can deliver an XSS payload. ### Details Old CVE fixed the XSS in label HTML but didn’t fix it when clicking save. ### PoC 1. Login at admin 2. Go to setting 3. Create a Section 4. On Entry page, click Edit label 5. Inject the XSS payload into the label and save 6. On the admin dashboard choose new widget -> Quick Post 7. In Quick Post, click save with blank slug; The XSS will be executed "errors":{"title":["<script>alert('nono')</script> cannot be blank."],"slug":["Slug cannot
O3 Security · Impact-Aware SCA

Is GHSA-3wxg-w96j-8hq9 in your dependencies?

Find it across Packagist, including transitive dependencies.

CraftCMS stored XSS in Quick Post widget error message