Undefined behaviour in `kvm_ioctls::ioctls::vm::VmFd::create_device`GHSA-3qx8-rv27-j6gp
Fix: rust-vmm/kvm#298GHSA-3qx8-rv27-j6gp is a security vulnerability in kvm-ioctls. A fix is available for kvm-ioctls — see the affected versions and patch details below.
Real-World Exposure
kvm-ioctlsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
An issue was identified in the VmFd::create_device function, leading to undefined behavior and miscompilations on rustc 1.82.0 and newer due to the function's violation of Rust's pointer safety rules.
The function downcasted a mutable reference to its struct kvm_create_device argument to an immutable pointer, and then proceeded to pass this pointer to a mutating system call. Rustc 1.82.0 and newer elides subsequent reads of this structure's fields, meaning code will not see the value written by the kernel into the fd member. Instead, the code will observe the value that this field was initialized to prior to calling VmFd::create_device (usually, 0).
The issue started in kvm-ioctls 0.1.0 and was fixed in 0.19.1 by correctly using a mutable pointer.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | kvm-ioctls | all versions | 0.19.1cargo update -p kvm-ioctls --precise 0.19.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for kvm-ioctls, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update kvm-ioctls to 0.19.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-3qx8-rv27-j6gp is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-3qx8-rv27-j6gp in your dependencies?
Find it across crates.io, including transitive dependencies.