NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

GraphQL queries can expose password hashesGHSA-3p7g-wrgg-wq45

Fix: ibexa/graphql@5ae5fb4

GHSA-3p7g-wrgg-wq45 is a security vulnerability in ibexa/graphql. A fix is available for ibexa/graphql — see the affected versions and patch details below.

Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Dec 2, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

3 pkgs affected
🐘ibexa/graphql🐘ibexa/graphql🐘ibexa/graphql

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Unauthenticated GraphQL queries for user accounts can expose password hashes of users that have created or modified content, typically but not necessarily limited to administrators and editors.

Patches

Affected versions: Ibexa DXP v3.3.*, v4.2.*, eZ Platform v2.5.* Resolving versions: Ibexa DXP v3.3.28, v4.2.3, eZ Platform v2.5.31

Workarounds

Remove the "passwordHash" entry from "src/bundle/Resources/config/graphql/User.types.yaml" in the GraphQL package, and other properties like hash type, email, login if you prefer.

References

This issue was reported to us by Philippe Tranca ("trancap") of the company Lexfo. We are very grateful for their research, and responsible disclosure to us of this critical vulnerability.

For more information

If you have any questions or comments about this advisory, please contact Support via your service portal.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistibexa/graphql≥ 2.5.0&&< 2.5.312.5.31composer require ibexa/graphql:^2.5.31
🐘Packagistibexa/graphql≥ 4.2.0&&< 4.2.34.2.3composer require ibexa/graphql:^4.2.3
🐘Packagistibexa/graphql≥ 3.3.0&&< 3.3.283.3.28composer require ibexa/graphql:^3.3.28

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ibexa/graphql, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ibexa/graphql to 2.5.31 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-3p7g-wrgg-wq45 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact Unauthenticated GraphQL queries for user accounts can expose password hashes of users that have created or modified content, typically but not necessarily limited to administrators and editors. ### Patches Affected versions: Ibexa DXP v3.3.\*, v4.2.\*, eZ Platform v2.5.\* Resolving versions: Ibexa DXP v3.3.28, v4.2.3, eZ Platform v2.5.31 ### Workarounds Remove the "passwordHash" entry from "src/bundle/Resources/config/graphql/User.types.yaml" in the GraphQL package, and other properties like hash type, email, login if you prefer. ### References This issue was reported to us by P
O3 Security · Impact-Aware SCA

Is GHSA-3p7g-wrgg-wq45 in your dependencies?

Find it across Packagist, including transitive dependencies.

GraphQL queries can expose password hashes