NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

node-ipc behavior changeGHSA-3mpp-xfvh-qh37

Fix: RIAEvangelist/node-ipc@a98efae

GHSA-3mpp-xfvh-qh37 is a security vulnerability in node-ipc. A fix is available for node-ipc — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Aug 14, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

427other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
node-ipcnpm
869Kdownloads / week

Description

node-ipc starting in version 11.0.0 and prior to version 12.0.0 includes a message from the maintainer that is written to the user’s desktop. Please review the version changes before proceeding.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmnode-ipc≥ 11.0.0&&< 12.0.012.0.0npm install node-ipc@12.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for node-ipc, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update node-ipc to 12.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-3mpp-xfvh-qh37 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

node-ipc starting in version 11.0.0 and prior to version 12.0.0 includes a message from the maintainer that is written to the user’s desktop. Please review the version changes before proceeding.
O3 Security · Impact-Aware SCA

Is GHSA-3mpp-xfvh-qh37 in your dependencies?

Find it across npm, including transitive dependencies.

GHSA-3mpp-xfvh-qh37: node-ipc — Fixed in 12.0.0