GHSA-3jrv-jgp8-45v3 is a high-severity (CVSS 7.4) CWE-444 vulnerability in io.undertow:undertow-core. A fix is available for io.undertow:undertow-core — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-3jrv-jgp8-45v3.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
io.undertow:undertow-core☕io.undertow:undertow-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in Undertow, which incorrectly parses cookies with certain value-delimiting characters in incoming requests. This issue could allow an attacker to construct a cookie value to exfiltrate HttpOnly cookie values or spoof arbitrary additional cookie values, leading to unauthorized data access or modification. The main threat from this flaw impacts data confidentiality and integrity.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.undertow:undertow-core | ≥ 2.3.0.Alpha1&&< 2.3.11.Final | 2.3.11.Finalio.undertow:undertow-core:2.3.11.Final |
| ☕Maven | io.undertow:undertow-core | all versions | 2.2.30.Finalio.undertow:undertow-core:2.2.30.Final |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.undertow:undertow-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.undertow:undertow-core to 2.3.11.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-3jrv-jgp8-45v3 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Migration Toolkit for Runtimes 1 on RHEL 8 | mtr/mtr-operator-bundle:1.2-23 | RHSA-2024:3919 |
| Red Hat JBoss Enterprise Application Platform 7.4.16 | io.undertow/undertow-core:2.2.30.SP1-redhat-00001 | RHSA-2024:1677 |
| Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 8 | eap7-undertow-0:2.2.30-1.SP1_redhat_00001.1.el8eap | RHSA-2024:1675 |
| Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 9 | eap7-undertow-0:2.2.30-1.SP1_redhat_00001.1.el9eap | RHSA-2024:1676 |
| Red Hat JBoss Enterprise Application Platform 7.4 on RHEL 7 | eap7-undertow-0:2.2.30-1.SP1_redhat_00001.1.el7eap | RHSA-2024:1674 |
| Red Hat JBoss Enterprise Application Platform 8 | undertow | RHSA-2024:2763 |
| Red Hat JBoss Enterprise Application Platform 8.0 for RHEL 8 | eap8-undertow-0:2.3.11-1.SP1_redhat_00001.1.el8eap | RHSA-2024:2764 |
Frequently Asked Questions
Is GHSA-3jrv-jgp8-45v3 in your dependencies?
Find it across Maven, including transitive dependencies.