NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
MEDIUM severity

GraphQL-Ruby's Ruby lexer does not count comment tokens for the purposes of max_query_string_tokensGHSA-3h96-34p3-xm76

MEDIUM

GHSA-3h96-34p3-xm76 is a medium-severity (CVSS 5.3) vulnerability in graphql. A fix is available for graphql — see the affected versions and patch details below.

Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of May 5, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

4 pkgs affected
💎graphql💎graphql💎graphql💎graphql

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

GraphQL-Ruby's max_query_string_tokens configuration didn't count comment tokens against the limit, allowing strings to be processed even after the configured maximum had actually been reached.

In patched versions, the Ruby lexer does count these tokens.

GraphQL-CParser is not affected by this problem.

max_query_string_tokens was introduced in v2.3.1. Each 2.x version has received a new patch release for including a fix.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsgraphql≥ 2.6.0&&< 2.6.12.6.1bundle update graphql --conservative
💎RubyGemsgraphql≥ 2.5.0&&< 2.5.262.5.26bundle update graphql --conservative
💎RubyGemsgraphql≥ 2.4.0&&< 2.4.182.4.18bundle update graphql --conservative
💎RubyGemsgraphql≥ 2.3.1&&< 2.3.232.3.23bundle update graphql --conservative

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for graphql, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update graphql to 2.6.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-3h96-34p3-xm76 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

GraphQL-Ruby's `max_query_string_tokens` configuration didn't count comment tokens against the limit, allowing strings to be processed even after the configured maximum had actually been reached. In patched versions, the Ruby lexer does count these tokens. GraphQL-CParser is not affected by this problem. `max_query_string_tokens` was introduced in v2.3.1. Each 2.x version has received a new patch release for including a fix.
O3 Security · Impact-Aware SCA

Is GHSA-3h96-34p3-xm76 in your dependencies?

Find it across RubyGems, including transitive dependencies.

GraphQL-Ruby's Ruby lexer does not count comment…