Magento 2 Community Unrestricted File UploadGHSA-3h69-4frw-g2jm
HIGHGHSA-3h69-4frw-g2jm is a high-severity (CVSS 7.2) Unrestricted File Upload vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
magento/community-edition🐘magento/community-edition🐘magento/community-editionReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A file upload restriction bypass exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with administrator privileges to the import feature can make modifications to a configuration file, resulting in potentially unauthorized removal of file upload restrictions. This can result in arbitrary code execution when a malicious file is then uploaded and executed on the system.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | magento/community-edition | ≥ 2.1&&< 2.1.18 | 2.1.18composer require magento/community-edition:^2.1.18 |
| 🐘Packagist | magento/community-edition | ≥ 2.2&&< 2.2.9 | 2.2.9composer require magento/community-edition:^2.2.9 |
| 🐘Packagist | magento/community-edition | ≥ 2.3&&< 2.3.2 | 2.3.2composer require magento/community-edition:^2.3.2 |
Affected Products
magentomagentoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update magento/community-edition to 2.1.18 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-3h69-4frw-g2jm is resolved across your whole dependency graph.
Workarounds
Treat uploaded files as untrusted until proven otherwise: validate the actual content type rather than the supplied extension, store uploads outside the web root on a volume mounted without execute permission, and rename them to server-generated identifiers so an attacker cannot choose the path a request will later resolve.
Frequently Asked Questions
Is GHSA-3h69-4frw-g2jm in your dependencies?
Find it across Packagist, including transitive dependencies.