NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

n8n: Credential exfiltration via Allowed HTTP Request Domains BypassGHSA-3875-8gcx-7v46

CRITICAL

GHSA-3875-8gcx-7v46 is a critical-severity (CVSS 9.1) Server-Side Request Forgery (SSRF) vulnerability in n8n. A fix is available for n8n — see the affected versions and patch details below.

Also known asCVE-2026-56348
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-3875-8gcx-7v46.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs42th percentile — riskier than 42% of all scored CVEsHighest risk
0.00%0.33%0.65%0.98%0.3%0.5%Jul 26Oct 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

36other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
n8nnpm
132Kdownloads / week

Description

Impact

The POST /rest/dynamic-node-parameters/options endpoint allowed any authenticated user to cause the n8n server to issue HTTP requests including credentials bypassing the intended restrictions on which hosts could be contacted for that credential (Allowed HTTP Request Domains). The user needed to be authenticated and have access to the credential.

Patches

The issue has been fixed in n8n version 2.20.0. Users should upgrade to this version or later to remediate the vulnerability.

Workarounds

If upgrading is not immediately possible, administrators should consider the following temporary mitigations:

  • Restrict n8n access to fully trusted users only.
  • Limit credential sharing to users who genuinely require access to those credentials.

These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmn8nall versions2.20.0npm install n8n@2.20.0

Affected Products

1 product · 2 configurations
Application
n8nn8n
< 2.20.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for n8n, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update n8n to 2.20.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-3875-8gcx-7v46 is resolved across your whole dependency graph.

  3. Workarounds

    Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.

Frequently Asked Questions

## Impact The `POST /rest/dynamic-node-parameters/options` endpoint allowed any authenticated user to cause the n8n server to issue HTTP requests including credentials bypassing the intended restrictions on which hosts could be contacted for that credential (Allowed HTTP Request Domains). The user needed to be authenticated and have access to the credential. ## Patches The issue has been fixed in n8n version 2.20.0. Users should upgrade to this version or later to remediate the vulnerability. ## Workarounds If upgrading is not immediately possible, administrators should consider the followin
O3 Security · Impact-Aware SCA

Is GHSA-3875-8gcx-7v46 in your dependencies?

Find it across npm, including transitive dependencies.

n8n: Credential exfiltration via Allowed HTTP Request…