NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

bn.js affected by an infinite loopGHSA-378v-28hj-76wf

MEDIUMFix: indutny/bn.js#317

GHSA-378v-28hj-76wf is a medium-severity (CVSS 5.3) CWE-835 vulnerability in bn.js. A fix is available for bn.js — see the affected versions and patch details below.

Also known asCVE-2026-2739
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.

Exploitation and automatability from CISA’s SSVC triage for GHSA-378v-28hj-76wf.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk-0.07%
Lower risk than most CVEs45th percentile — riskier than 45% of all scored CVEsHighest risk
0.00%0.37%0.73%1.10%0.0%0.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

6Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
bn.jsnpm
83.0Mdownloads / week

Description

This affects versions of the package bn.js before 4.12.3 and 5.2.3. Calling maskn(0) on any BN instance corrupts the internal state, causing toString(), divmod(), and other methods to enter an infinite loop, hanging the process indefinitely.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmbn.jsall versions4.12.3npm install bn.js@4.12.3
📦npmbn.js≥ 5.0.0&&< 5.2.35.2.3npm install bn.js@5.2.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for bn.js, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update bn.js to 4.12.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-378v-28hj-76wf is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

This affects versions of the package bn.js before 4.12.3 and 5.2.3. Calling maskn(0) on any BN instance corrupts the internal state, causing toString(), divmod(), and other methods to enter an infinite loop, hanging the process indefinitely.
O3 Security · Impact-Aware SCA

Is GHSA-378v-28hj-76wf in your dependencies?

Find it across npm, including transitive dependencies.

GHSA-378v-28hj-76wf: bn.js — Fixed in 4.12.3