OpenClaw: Discord DM reaction ingress missed dmPolicy/allowFrom checks in restricted setupsGHSA-354r-7mfh-7rh2
LOWFix: openclaw/openclaw@aedf62aGHSA-354r-7mfh-7rh2 is a low-severity (CVSS 3.7) CWE-863 vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-354r-7mfh-7rh2.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
openclawnpmDescription
Summary
In OpenClaw <= 2026.2.24, Discord direct-message reaction notifications did not consistently apply the same DM authorization checks (dmPolicy / allowFrom) that are enforced for normal DM message ingress.
In restrictive DM setups, a non-allowlisted Discord user who can react to a bot-authored DM message could still enqueue a reaction-derived system event in the session.
This is a reaction-only ingress inconsistency. By itself it does not directly execute commands; practical impact depends on downstream automation/tool policy.
Details
The DM message path already enforces dmPolicy/allowFrom authorization, but the DM reaction-notification path previously allowed event enqueue under reaction mode checks without that same authorization gate.
Fix in main aligns reaction ingress with normal message preflight for Discord DM/group-DM/guild policy boundaries and applies equivalent DM reaction authorization hardening for Slack to keep channel behavior consistent.
Affected Packages / Versions
npmpackage:openclaw- Affected:
<= 2026.2.24 - Patched:
>= 2026.2.25
Fix Commit(s)
aedf62ac7e669a89c7b299201bf6537dc6b12e0e
Release Process Note
patched_versions is pre-set to the release (2026.2.25) so after npm release the advisory is published.
Thanks @tdjackey for reporting.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | openclaw | all versions | 2026.2.25npm install openclaw@2026.2.25 |
Affected Products
openclawopenclawDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update openclaw to 2026.2.25 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-354r-7mfh-7rh2 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-354r-7mfh-7rh2 in your dependencies?
Find it across npm, including transitive dependencies.