NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

Parse Dashboard is Missing CSRF Protection for its Agent EndpointGHSA-3534-xp88-25rc

GHSA-3534-xp88-25rc is a Cross-Site Request Forgery (CSRF) vulnerability in parse-dashboard. A fix is available for parse-dashboard — see the affected versions and patch details below.

Also known asCVE-2026-27609
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-3534-xp88-25rc.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs6th percentile — riskier than 6% of all scored CVEsHighest risk
0.00%0.23%0.45%0.68%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

25other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
parse-dashboardnpm
10Kdownloads / week

Description

Impact

The AI Agent API endpoint (POST /apps/:appId/agent) lacks CSRF protection. An attacker can craft a malicious page that, when visited by an authenticated dashboard user, submits requests to the agent endpoint using the victim's session.

Patches

The fix adds CSRF middleware to the agent endpoint and embeds a CSRF token in the dashboard page.

Workarounds

Remove the agent configuration block from your dashboard configuration. Dashboards without an agent config are not affected.

Resources

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmparse-dashboard≥ 7.3.0-alpha.42&&< 9.0.0-alpha.89.0.0-alpha.8npm install parse-dashboard@9.0.0-alpha.8

Affected Products

1 product · 135 configurations
Application
parse dashboardparseplatform
13 versions
7.3.07.4.07.5.07.6.08.0.08.1.08.1.18.2.08.3.08.4.08.4.18.5.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for parse-dashboard, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update parse-dashboard to 9.0.0-alpha.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-3534-xp88-25rc is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact The AI Agent API endpoint (`POST /apps/:appId/agent`) lacks CSRF protection. An attacker can craft a malicious page that, when visited by an authenticated dashboard user, submits requests to the agent endpoint using the victim's session. ### Patches The fix adds CSRF middleware to the agent endpoint and embeds a CSRF token in the dashboard page. ### Workarounds Remove the `agent` configuration block from your dashboard configuration. Dashboards without an `agent` config are not affected. ### Resources - GitHub advisory: https://github.com/parse-community/parse-dashboard/secur
O3 Security · Impact-Aware SCA

Is GHSA-3534-xp88-25rc in your dependencies?

Find it across npm, including transitive dependencies.

Parse Dashboard is Missing CSRF Protection for its Agent…