Krayin CRM allows a remote attacker to execute arbitrary code via compose email functionGHSA-32px-ccfx-cxq3
HIGHGHSA-32px-ccfx-cxq3 is a high-severity (CVSS 8.1) Code Injection vulnerability in krayin/laravel-crm. A fix is available for krayin/laravel-crm — see the affected versions and patch details below.
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for GHSA-32px-ccfx-cxq3.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
krayin/laravel-crmReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue in Krayin CRM v.2.1.5, which was fixed in v.2.1.6 allows a remote attacker to execute arbitrary code via the compose email function.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | krayin/laravel-crm | ≥ 2.1.5&&< 2.1.6 | 2.1.6composer require krayin/laravel-crm:^2.1.6 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for krayin/laravel-crm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update krayin/laravel-crm to 2.1.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-32px-ccfx-cxq3 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is GHSA-32px-ccfx-cxq3 in your dependencies?
Find it across Packagist, including transitive dependencies.