NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CKAN may leak Solr credentials via error message in package_search actionGHSA-2rqw-cfhc-35fh

MEDIUMFix: ckan/ckan@f6b032c

GHSA-2rqw-cfhc-35fh is a medium-severity (CVSS 5.3) CWE-209 vulnerability in ckan. A fix is available for ckan — see the affected versions and patch details below.

Also known asCVE-2024-41674PYSEC-2026-1248
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-2rqw-cfhc-35fh.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs32th percentile — riskier than 32% of all scored CVEsHighest risk
0.00%0.33%0.65%0.97%0.5%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍ckan

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

CKAN is an open-source data management system for powering data hubs and data portals. If there were connection issues with the Solr server, the internal Solr URL (potentially including credentials) could be leaked to package_search calls as part of the returned error message. This has been patched in CKAN 2.10.5 and 2.11.0.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIckan≥ 2.0.0&&< 2.10.52.10.5pip install --upgrade 'ckan==2.10.5'

Affected Products

1 product · 1 configurations
Application
ckanokfn
≥ 2.0 && < 2.10.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ckan, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ckan to 2.10.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2rqw-cfhc-35fh is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

If there were connection issues with the Solr server, the internal Solr URL (potentially including credentials) could be leaked to `package_search` calls as part of the returned error message ### Patches This has been patched in CKAN 2.10.5 and 2.11.0
O3 Security · Impact-Aware SCA

Is GHSA-2rqw-cfhc-35fh in your dependencies?

Find it across PyPI, including transitive dependencies.

CKAN may leak Solr credentials via error message in…