CKAN vulnerable to stored XSS in resource descriptionGHSA-2r4h-8jxv-w2j8
MEDIUMFix: ckan/ckan@112afffGHSA-2r4h-8jxv-w2j8 is a medium-severity (CVSS 6.3) Cross-site Scripting (XSS) vulnerability in ckan. A fix is available for ckan — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-2r4h-8jxv-w2j8.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ckan🐍ckanReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
CKAN is an open-source DMS (data management system) for powering data hubs and data portals. Prior to 2.10.9 and 2.11.4, the helpers.markdown_extract() function did not perform sufficient sanitization of input data before wrapping in an HTML literal element. This helper is used to render user-provided data on dataset, resource, organization or group pages (plus any page provided by an extension that used that helper function), leading to a potential XSS vector. This vulnerability has been fixed in CKAN 2.10.9 and 2.11.4.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | ckan | ≥ 2.11.0&&< 2.11.4 | 2.11.4pip install --upgrade 'ckan==2.11.4' |
| 🐍PyPI | ckan | all versions | 2.10.9pip install --upgrade 'ckan==2.10.9' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ckan, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ckan to 2.11.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2r4h-8jxv-w2j8 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-2r4h-8jxv-w2j8 in your dependencies?
Find it across PyPI, including transitive dependencies.