FuelVM is vulnerable to heap memory allocation re-use bugGHSA-2pgj-5cv2-6xxw
Fix: FuelLabs/fuel-vm#941GHSA-2pgj-5cv2-6xxw is a security vulnerability in fuel-vm. A fix is available for fuel-vm — see the affected versions and patch details below.
Real-World Exposure
fuel-vm🦀fuel-vmReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A memory safety vulnerability was present in the Fuel Virtual Machine (FuelVM), where memory reads could bypass expected access controls. Specifically, when a smart contract performed a mload (or other opcodes which access memory) on memory that had been deallocated using ret, it was still able to access the old memory contents. This occurred because the memory region was not zeroed out or otherwise marked as invalid. As a result, smart contracts could potentially read sensitive data left over from other contracts if the same memory was reallocated, violating isolation guarantees between contracts and enabling unintended data leakage.
All users running affected versions of FuelVM that relied on strict memory isolation between smart contracts were impacted.
Patches
The vulnerability was patched by modifying the FuelVM to ensure that memory deallocated with ret was zeroed out or made inaccessible. The fix was included in FuelVM version v0.60.1 and back-ported to v0.59.3. This patch was released to the Fuel network on Friday, April 18th, 2025.
Workarounds
There were no reliable workarounds that fully mitigated the vulnerability. While developers could manually zero out sensitive memory regions before returning from a function, this approach was error-prone and could not be enforced at the VM level. Upgrading to a patched version remained the recommended course of action.
References
- Fix implemented in the FuelVM GitHub repository (https://github.com/FuelLabs/fuel-vm/pull/941)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | fuel-vm | all versions | 0.59.3cargo update -p fuel-vm --precise 0.59.3 |
| 🦀crates.io | fuel-vm | ≥ 0.60.0&&< 0.60.1 | 0.60.1cargo update -p fuel-vm --precise 0.60.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for fuel-vm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update fuel-vm to 0.59.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2pgj-5cv2-6xxw is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-2pgj-5cv2-6xxw in your dependencies?
Find it across crates.io, including transitive dependencies.