NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CodeIgniter arbitrary code executionGHSA-2pcj-76hj-xqhm

CRITICALFix: bcit-ci/CodeIgniter@8db01f1

GHSA-2pcj-76hj-xqhm is a critical-severity (CVSS 9.8) CWE-74 vulnerability in bcit-ci/codeigniter. A fix is available for bcit-ci/codeigniter — see the affected versions and patch details below.

Also known asCVE-2016-10131
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs88th percentile — riskier than 88% of all scored CVEsHighest risk
2.59%2.93%3.28%3.63%3.1%3.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘bcit-ci/codeigniter

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

system/libraries/Email.php in CodeIgniter before 3.1.3 allows remote attackers to execute arbitrary code by leveraging control over the email->from field to insert sendmail command-line arguments.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistbcit-ci/codeigniterall versions3.1.3composer require bcit-ci/codeigniter:^3.1.3

Affected Products

1 product · 1 configurations
Application
codeignitercodeigniter
≤ 3.1.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for bcit-ci/codeigniter, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update bcit-ci/codeigniter to 3.1.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2pcj-76hj-xqhm is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

system/libraries/Email.php in CodeIgniter before 3.1.3 allows remote attackers to execute arbitrary code by leveraging control over the email->from field to insert sendmail command-line arguments.
O3 Security · Impact-Aware SCA

Is GHSA-2pcj-76hj-xqhm in your dependencies?

Find it across Packagist, including transitive dependencies.

CodeIgniter arbitrary code execution (Critical 9.8)