NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

cleo is vulnerable to Regular Expression Denial of Service (ReDoS)GHSA-2p9h-ccw7-33gf

MEDIUMFix: python-poetry/cleo#285

GHSA-2p9h-ccw7-33gf is a medium-severity (CVSS 5.9) CWE-1333 vulnerability in cleo. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for cleo — see the affected versions and patch details below.

Also known asCVE-2022-42966PYSEC-2022-43178
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-2p9h-ccw7-33gf.

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs63th percentile — riskier than 63% of all scored CVEsHighest risk
0.00%0.50%0.99%1.49%0.3%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍cleo

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the cleo PyPI package, when an attacker is able to supply arbitrary input to the Table.set_rows method.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIcleo≥ 1.0.0a1&&< 2.0.02.0.0pip install --upgrade 'cleo==2.0.0'

Affected Products

1 product · 1 configurations
Application
cleopython-poetry
< 2.0.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cleo, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cleo to 2.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2p9h-ccw7-33gf is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the cleo PyPI package, when an attacker is able to supply arbitrary input to the Table.set_rows method.
O3 Security · Impact-Aware SCA

Is GHSA-2p9h-ccw7-33gf in your dependencies?

Find it across PyPI, including transitive dependencies.

cleo is vulnerable to Regular Expression Denial of Service…