NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

ibexa/admin-ui has an XSS vulnerability in Cancel/Reschedule future publication modalGHSA-2mx6-fq24-g2mh

GHSA-2mx6-fq24-g2mh is a security vulnerability in ibexa/admin-ui. A fix is available for ibexa/admin-ui — see the affected versions and patch details below.

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 17, 2025 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🐘ibexa/admin-ui🐘ibexa/admin-ui

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

This security advisory resolves an XSS vulnerability in image asset names, content language names and future publishing in the back office of the DXP. Back office access and varying levels of editing and management permissions are required to exploit this vulnerability. This typically means Editor or Administrator role, or similar. Injected XSS is persistent and may in some cases be reflected in the front office, possibly affecting end users. The fixes ensure XSS is escaped, and any existing injected XSS is rendered harmless.

Patches

See "Patched versions".

Workarounds

None.

References

https://developers.ibexa.co/security-advisories/ibexa-sa-2025-004-xss-and-enumeration-vulnerabilities-in-back-office

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistibexa/admin-ui≥ 5.0.0&&< 5.0.35.0.3composer require ibexa/admin-ui:^5.0.3
🐘Packagistibexa/admin-ui≥ 4.6.0&&< 4.6.254.6.25composer require ibexa/admin-ui:^4.6.25

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ibexa/admin-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ibexa/admin-ui to 5.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2mx6-fq24-g2mh is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Impact This security advisory resolves an XSS vulnerability in image asset names, content language names and future publishing in the back office of the DXP. Back office access and varying levels of editing and management permissions are required to exploit this vulnerability. This typically means Editor or Administrator role, or similar. Injected XSS is persistent and may in some cases be reflected in the front office, possibly affecting end users. The fixes ensure XSS is escaped, and any existing injected XSS is rendered harmless. ### Patches See "Patched versions". ### Workarounds Non
O3 Security · Impact-Aware SCA

Is GHSA-2mx6-fq24-g2mh in your dependencies?

Find it across Packagist, including transitive dependencies.

ibexa/admin-ui has an XSS vulnerability in…