Liferay Portal and Liferay DXP HTTP Header Can Expose VersionsGHSA-2mvj-q2q3-wxjv
MEDIUMFix: liferay/liferay-portal@00750daGHSA-2mvj-q2q3-wxjv is a medium-severity (CVSS 5.3) CWE-1188 vulnerability in com.liferay.portal:release.portal.bom. A fix is available for com.liferay.portal:release.portal.bom — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-2mvj-q2q3-wxjv.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
com.liferay.portal:release.portal.bom☕com.liferay.portal:release.dxp.bom☕com.liferay.portal:release.dxp.bom☕com.liferay.portal:release.dxp.bomReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Liferay Portal 7.2.0 through 7.4.3.25, and older unsupported versions, and Liferay DXP 7.4 before update 26, 7.3 before update 5, 7.2 before fix pack 19, and older unsupported versions the default value of the portal property http.header.version.verbosity is set to full, which allows remote attackers to easily identify the version of the application that is running and the vulnerabilities that affect that version via 'Liferay-Portal` response header.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.liferay.portal:release.portal.bom | ≥ 7.2.0&&< 7.4.3.26-ga26 | 7.4.3.26-ga26com.liferay.portal:release.portal.bom:7.4.3.26-ga26 |
| ☕Maven | com.liferay.portal:release.dxp.bom | all versions | 7.2.10.fp19com.liferay.portal:release.dxp.bom:7.2.10.fp19 |
| ☕Maven | com.liferay.portal:release.dxp.bom | ≥ 7.3.0&&< 7.3.10.u5 | 7.3.10.u5com.liferay.portal:release.dxp.bom:7.3.10.u5 |
| ☕Maven | com.liferay.portal:release.dxp.bom | ≥ 7.4.0&&< 7.4.13.u26 | 7.4.13.u26com.liferay.portal:release.dxp.bom:7.4.13.u26 |
Affected Products
digital experience platformliferayliferay portalliferayDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.liferay.portal:release.portal.bom, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.liferay.portal:release.portal.bom to 7.4.3.26-ga26 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2mvj-q2q3-wxjv is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-2mvj-q2q3-wxjv in your dependencies?
Find it across Maven, including transitive dependencies.