GHSA-2jx8-v4hv-gx3h is a high-severity (CVSS 7.5) XML External Entity (XXE) vulnerability in com.epam.reportportal:service-api. A fix is available for com.epam.reportportal:service-api — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
com.epam.reportportal:service-api☕com.epam.reportportal:service-apiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
| Release Date | Affected Projects | Affected Versions | Access Vector | Security Risk |
|---|---|---|---|---|
| Monday, May 4, 2020 | service-api | Every version, starting from 3.1.0 | Remote | Medium |
Impact
Starting from version 3.1.0 we introduced a new feature of JUnit XML launch import. Unfortunately XML parser was not configured properly to prevent XML external entity (XXE) attacks. This allows a user to import a specifically-crafted XML file that uses external entities for extraction of secrets from Report Portal service-api module or server-side request forgery.
Report Portal versions 4.3.12+ and 5.1.1+ disables external entity resolution for theirs XML parser.
We advise our users install the latest releases we built specifically to address this issue.
Patches
Fixed with https://github.com/reportportal/service-api/pull/1201
Binary Download
https://bintray.com/epam/reportportal/service-api/5.1.1 https://bintray.com/epam/reportportal/service-api/4.3.12
Docker Container Download
- RP v4:
docker pull reportportal/service-api:4.3.12 - RP v5:
docker pull reportportal/service-api:5.1.1
Acknowledgement
The issue was reported to Report Portal Team by an external security researcher. Our Team thanks Julien M. for reporting the issue.
For more information
If you have any questions or comments about this advisory email us: [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.epam.reportportal:service-api | ≥ 3.1.0&&< 4.3.12 | 4.3.12com.epam.reportportal:service-api:4.3.12 |
| ☕Maven | com.epam.reportportal:service-api | ≥ 5.0.0&&< 5.1.1 | 5.1.1com.epam.reportportal:service-api:5.1.1 |
Affected Products
service-apireportportalDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.epam.reportportal:service-api, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.epam.reportportal:service-api to 4.3.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2jx8-v4hv-gx3h is resolved across your whole dependency graph.
Workarounds
Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.
Frequently Asked Questions
Is GHSA-2jx8-v4hv-gx3h in your dependencies?
Find it across Maven, including transitive dependencies.