NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 SwiftURL
Not in CISA KEV

Incomplete Internal State Distinction in GRPCWebToHTTP2ServerCodecGHSA-2jx2-qcm4-rf9h

GHSA-2jx2-qcm4-rf9h is a security vulnerability in github.com/grpc/grpc-swift. A fix is available for github.com/grpc/grpc-swift — see the affected versions and patch details below.

Also known asCVE-2021-36153
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 8, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
0.86%1.43%2.01%2.58%1.4%2.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
📦github.com/grpc/grpc-swift

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects SwiftURL packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Affected gRPC Swift servers are vulnerable to precondition failures when parsing certain gRPC Web requests. This may lead to a denial of service.

Patches

The problem has been fixed in 1.2.0.

Workarounds

No workaround is available. Users must upgrade.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦SwiftURLgithub.com/grpc/grpc-swiftall versions1.2.0

Affected Products

1 product · 2 configurations
Application
grpc swiftlinuxfoundation
2 versions
1.1.01.1.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/grpc/grpc-swift, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/grpc/grpc-swift to 1.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2jx2-qcm4-rf9h is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

### Impact Affected gRPC Swift servers are vulnerable to precondition failures when parsing certain gRPC Web requests. This may lead to a denial of service. ### Patches The problem has been fixed in 1.2.0. ### Workarounds No workaround is available. Users must upgrade.
O3 Security · Impact-Aware SCA

Is GHSA-2jx2-qcm4-rf9h in your dependencies?

Find it across SwiftURL, including transitive dependencies.

Incomplete Internal State Distinction in…