NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Moodle Does Not Escape Characters In Email HeadersGHSA-2hh3-jmv8-5fmx

MEDIUMFix: moodle/moodle@ed63718

GHSA-2hh3-jmv8-5fmx is a medium-severity (CVSS 5.4) CWE-74 vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Also known asCVE-2016-5013
Published
Updated
Affected
5 pkgs
Patched
4 / 5
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs64th percentile — riskier than 64% of all scored CVEsHighest risk
0.00%0.52%1.04%1.56%0.4%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

In Moodle 2.x and 3.x, text injection can occur in email headers, potentially leading to outbound spam.

Affected Packages

5 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 3.1&&< 3.1.13.1.1composer require moodle/moodle:^3.1.1
🐘Packagistmoodle/moodle≥ 3.0&&< 3.0.53.0.5composer require moodle/moodle:^3.0.5
🐘Packagistmoodle/moodle≥ 2.9&&< 2.9.72.9.7composer require moodle/moodle:^2.9.7
🐘Packagistmoodle/moodle≥ 2.8No fix
🐘Packagistmoodle/moodle≥ 2.7&&< 2.7.152.7.15composer require moodle/moodle:^2.7.15

Affected Products

1 product · 27 configurations
Application
moodlemoodle
≤ 2.7.14
26 versions
2.8.02.8.12.8.22.8.32.8.42.8.52.8.62.8.72.8.82.8.92.8.102.8.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 3.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2hh3-jmv8-5fmx is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

In Moodle 2.x and 3.x, text injection can occur in email headers, potentially leading to outbound spam.
O3 Security · Impact-Aware SCA

Is GHSA-2hh3-jmv8-5fmx in your dependencies?

Find it across Packagist, including transitive dependencies.

Moodle Does Not Escape Characters In Email Headers