NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

Numpy arbitrary file write via symlink attackGHSA-2fc2-6r4j-p65h

MEDIUMFix: numpy/numpy#4262

GHSA-2fc2-6r4j-p65h is a medium-severity (CVSS 5.5) CWE-59 vulnerability in numpy. A fix is available for numpy — see the affected versions and patch details below.

Also known asCVE-2014-1859PYSEC-2018-34
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs41th percentile — riskier than 41% of all scored CVEsHighest risk
0.00%0.32%0.65%0.97%0.0%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍numpy

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

(1) core/tests/test_memmap.py, (2) core/tests/test_multiarray.py, (3) f2py/f2py2e.py, and (4) lib/tests/test_io.py in NumPy before 1.8.1 allow local users to write to arbitrary files via a symlink attack on a temporary file.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPInumpyall versions1.8.1pip install --upgrade 'numpy==1.8.1'

Affected Products

3 products · 6 configurations
OS
fedorafedoraproject
2 versions
1920
Application
numpynumpy
≤ 1.8.0
1 version
1.8.1
OS
enterprise linuxredhat
2 versions
6.07.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for numpy, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update numpy to 1.8.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2fc2-6r4j-p65h is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

(1) core/tests/test_memmap.py, (2) core/tests/test_multiarray.py, (3) f2py/f2py2e.py, and (4) lib/tests/test_io.py in NumPy before 1.8.1 allow local users to write to arbitrary files via a symlink attack on a temporary file.
O3 Security · Impact-Aware SCA

Is GHSA-2fc2-6r4j-p65h in your dependencies?

Find it across PyPI, including transitive dependencies.

Numpy arbitrary file write via symlink attack (Medium 5.5)