Laravel Cross-site Scripting vulnerability in blade templatingGHSA-297g-xg4h-7w4c
MEDIUMFix: laravel/framework#31945GHSA-297g-xg4h-7w4c is a medium-severity (CVSS 4.7) vulnerability in illuminate/view. A fix is available for illuminate/view — see the affected versions and patch details below.
Real-World Exposure
illuminate/viewReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Laravel is prone to a Cross-site Scripting vulnerability in blade templating.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | illuminate/view | ≥ 7.0.0&&< 7.1.2 | 7.1.2composer require illuminate/view:^7.1.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for illuminate/view, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update illuminate/view to 7.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-297g-xg4h-7w4c is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-297g-xg4h-7w4c in your dependencies?
Find it across Packagist, including transitive dependencies.