Client Denial of Service on TUFGHSA-2828-9vh6-9m6j
MEDIUMGHSA-2828-9vh6-9m6j is a medium-severity (CVSS 5.3) Uncontrolled Resource Consumption vulnerability in tuf. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for tuf — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tufReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
An attacker who can gain file access to the repository and modify metadata files may cause a denial of service to clients by creating many invalid signatures on a metadata file. Having a large number of signatures to verify will delay the moment when the client will determine the signature is not valid. This delay may be for at least a few minutes, but possibly could be longer especially if multiple files are impacted.
The tuf maintainers would like to thank Erik MacLean of Analog Devices, Inc. for reporting this issue.
Patches
No fix exists for this issue.
Workarounds
No workarounds are known for this issue.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | tuf | ≥ 0.7.2&&< 0.12.2 | 0.12.2pip install --upgrade 'tuf==0.12.2' |
Affected Products
the update frameworklinuxfoundationResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tuf, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tuf to 0.12.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2828-9vh6-9m6j is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is GHSA-2828-9vh6-9m6j in your dependencies?
Find it across PyPI, including transitive dependencies.