GHSA-273r-v888-vgc6 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
magento/community-edition🐘magento/community-editionReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A mitigation bypass to prevent cross-site scripting (XSS) exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. Successful exploitation of this vulnerability would result in an attacker being able to bypass the escapeURL() function and execute a malicious XSS payload.
As per the Magento Release 2.3.3, if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | magento/community-edition | ≥ 2.2.0&&< 2.2.10 | 2.2.10composer require magento/community-edition:^2.2.10 |
| 🐘Packagist | magento/community-edition | ≥ 2.3.0&&< 2.3.2-p2 | 2.3.2-p2composer require magento/community-edition:^2.3.2-p2 |
Affected Products
magentomagentoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update magento/community-edition to 2.2.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-273r-v888-vgc6 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-273r-v888-vgc6 in your dependencies?
Find it across Packagist, including transitive dependencies.