NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

PheonixAppAPI has visible Encoding MapsGHSA-258h-f687-4226

MEDIUMFix: AkshuDev/PheonixAppAPI@0937419

GHSA-258h-f687-4226 is a medium-severity (CVSS 4.4) CWE-323 vulnerability in pheonixappapi. A fix is available for pheonixappapi — see the affected versions and patch details below.

Also known asCVE-2024-41951PYSEC-2026-1779
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 8, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-258h-f687-4226.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs6th percentile — riskier than 6% of all scored CVEsHighest risk
0.00%0.22%0.45%0.67%0.1%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍pheonixappapi

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

This is a kind of moderate issue. The impact is not big for normal users but can be for users who want to secure their code/files/etc.

The issue is that the map of encoding/decoding languages are visible in code.

Patches

The Problem was patched in 0.2.5, so you should try to upgrade to the 0.2.5 version.

For 0.2.5 version users

Please run the post_install.py file inside the Scripts folder after downloading from pip.

Workarounds

There is a fix to this problem but it requires modifying the code. Modifying the code can lead to more issues.

References

There are currently no references to this problem.

NOTE: If you get a error regarding a function like -> get_key() or something like that, please re-run the file post_install.py inside Scripts folder

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpheonixappapiall versions0.2.5pip install --upgrade 'pheonixappapi==0.2.5'

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pheonixappapi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pheonixappapi to 0.2.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-258h-f687-4226 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact This is a kind of moderate issue. The impact is not big for normal users but can be for users who want to secure their code/files/etc. The issue is that the map of encoding/decoding languages are visible in code. ### Patches The Problem was patched in 0.2.5, so you should try to upgrade to the 0.2.5 version. ### For 0.2.5 version users Please run the post_install.py file inside the Scripts folder after downloading from pip. ### Workarounds There is a fix to this problem but it requires modifying the code. Modifying the code can lead to more issues. ### References There are cur
O3 Security · Impact-Aware SCA

Is GHSA-258h-f687-4226 in your dependencies?

Find it across PyPI, including transitive dependencies.

PheonixAppAPI has visible Encoding Maps (Medium 4.4)