Apache NiFi Insufficient Property Validation vulnerabilityGHSA-23qf-3jf9-h3q9
MEDIUMFix: apache/nifi#7586GHSA-23qf-3jf9-h3q9 is a medium-severity (CVSS 6.5) CWE-184 vulnerability in org.apache.nifi:nifi-dbcp-base. A fix is available for org.apache.nifi:nifi-dbcp-base — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-23qf-3jf9-h3q9.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.nifi:nifi-dbcp-base☕org.apache.nifi:nifi-jms-processors☕org.apache.nifi:nifi-dbcp-service-api☕org.apache.nifi:nifi-dbcp-service-bundleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache NiFi 1.21.0 through 1.23.0 support JDBC and JNDI JMS access in several Processors and Controller Services with connection URL validation that does not provide sufficient protection against crafted inputs. An authenticated and authorized user can bypass connection URL validation using custom input formatting. The resolution enhances connection URL validation and introduces validation for additional related properties. Upgrading to Apache NiFi 1.23.1 is the recommended mitigation.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.nifi:nifi-dbcp-base | ≥ 1.21.0&&< 1.23.1 | 1.23.1org.apache.nifi:nifi-dbcp-base:1.23.1 |
| ☕Maven | org.apache.nifi:nifi-jms-processors | ≥ 1.21.0&&< 1.23.1 | 1.23.1org.apache.nifi:nifi-jms-processors:1.23.1 |
| ☕Maven | org.apache.nifi:nifi-dbcp-service-api | ≥ 1.21.0&&< 1.23.1 | 1.23.1org.apache.nifi:nifi-dbcp-service-api:1.23.1 |
| ☕Maven | org.apache.nifi:nifi-dbcp-service-bundle | ≥ 1.21.0&&< 1.23.1 | 1.23.1org.apache.nifi:nifi-dbcp-service-bundle:1.23.1 |
Affected Products
nifiapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.nifi:nifi-dbcp-base, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.nifi:nifi-dbcp-base to 1.23.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-23qf-3jf9-h3q9 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-23qf-3jf9-h3q9 in your dependencies?
Find it across Maven, including transitive dependencies.