TYPO3 Cross-Site Scripting in Fluid ViewHelpersGHSA-22q7-cg4r-p9mx
MEDIUMFix: TYPO3-CMS/fluid@1a65dccGHSA-22q7-cg4r-p9mx is a medium-severity (CVSS 6.1) vulnerability in typo3/cms-fluid. A fix is available for typo3/cms-fluid — see the affected versions and patch details below.
Real-World Exposure
typo3/cms-fluid🐘typo3/cms-fluidReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Failing to properly encode user input, templates using built-in Fluid ViewHelpers are vulnerable to cross-site scripting.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms-fluid | ≥ 8.0.0&&< 8.7.23 | 8.7.23composer require typo3/cms-fluid:^8.7.23 |
| 🐘Packagist | typo3/cms-fluid | ≥ 9.0.0&&< 9.5.4 | 9.5.4composer require typo3/cms-fluid:^9.5.4 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-fluid, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms-fluid to 8.7.23 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-22q7-cg4r-p9mx is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-22q7-cg4r-p9mx in your dependencies?
Find it across Packagist, including transitive dependencies.