Statamic: Missing authorization on Control Panel endpoint allows disclosure of user existenceGHSA-225x-3jhx-wh4q
MEDIUMFix: statamic/cms#14905GHSA-225x-3jhx-wh4q is a medium-severity (CVSS 4.3) Information Exposure vulnerability in statamic/cms. A fix is available for statamic/cms — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-225x-3jhx-wh4q.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
statamic/cms🐘statamic/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Statamic is a Laravel and Git powered content management system (CMS). Prior to 5.74.1 and 6.24.0, an authenticated Control Panel user could use an endpoint intended for the user creation wizard to determine if a given email address belonged to an existing user, without having permission to view users, though the endpoint only exposed user existence and not any other user data. This issue is fixed in versions 5.74.1 and 6.24.0.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | statamic/cms | all versions | 5.74.1composer require statamic/cms:^5.74.1 |
| 🐘Packagist | statamic/cms | ≥ 6.0.0&&< 6.24.0 | 6.24.0composer require statamic/cms:^6.24.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for statamic/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update statamic/cms to 5.74.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-225x-3jhx-wh4q is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-225x-3jhx-wh4q in your dependencies?
Find it across Packagist, including transitive dependencies.