CVE-2026-92599 — joi
Fix: hapijs/joi#3143CVE-2026-92599 is a CWE-1333 vulnerability in joi. A fix is available for joi — see the affected versions and patch details below.
Joi before 17.13.7 and 18.2.6 ReDoS via isoDate
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-92599.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
joinpmDescription
joi (npm package joi, hapi.js) versions >=17.2.0 <17.13.7 and >=18.0.0 <18.2.6 are vulnerable to regular expression denial of service in the Joi.string().isoDate() validation rule. One of the regular expressions the rule applies to the input is unanchored, so a valid ISO date followed by a long run of fractional-second digits causes the regex engine to restart its search from every position in the string, yielding time proportional to the square of the input length (about 1.4 s for 64 KB of digits and about 22 s for 256 KB). A remote attacker who can supply a string to an isoDate validation can stall the application with a single request. Fixed in 17.13.7 and 18.2.6; as a workaround, cap the length of the string before it reaches joi.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | joi | ≥ 17.2.0&&< 17.13.7 | 17.13.7npm install joi@17.13.7 |
| 📦npm | joi | ≥ 18.0.0&&< 18.2.6 | 18.2.6npm install joi@18.2.6 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for joi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update joi to 17.13.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-92599 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This is an Important denial of service vulnerability as it can be exploited remotely without authentication. An unanchored regular expression in the `isoDate` validation rule of the `joi` library allows an attacker to provide a crafted input, leading to excessive resource consumption and application unresponsiveness.…
To mitigate this vulnerability, ensure that any input strings processed by the `Joi.string().isoDate()` validation rule are capped in length before being passed to the 'joi' package. This can prevent the regular expression engine from consuming excessive resources and causing a denial of service.Source: Red Hat security advisory for CVE-2026-92599 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Hardened Images | grafana13-2-main-13.2.1-0.5.hum1 | RHSA-2026:68778 |
| Red Hat Hardened Images | grafana12-4-main-12.4.10-0.6.hum1 | RHSA-2026:68821 |
| Red Hat Hardened Images | grafana13-1-main-13.1.6-0.2.hum1 | RHSA-2026:68926 |
| Red Hat Migration Toolkit 1.8 | rhmtc/openshift-migration-ui-rhel8:1791853281 | RHSA-2026:85846 |
| Red Hat OpenShift AI 2.25 | rhoai/odh-dashboard-rhel9:1791853525 | RHSA-2026:87410 |
| Red Hat OpenShift AI 3.4 | rhoai/odh-dashboard-rhel9:1793001801 | RHSA-2026:92510 |
Frequently Asked Questions
Is CVE-2026-92599 in your dependencies?
Find it across npm, including transitive dependencies.