CVE-2026-88976 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in @platejs/core. A fix is available for @platejs/core — see the affected versions and patch details below.
@platejs/core HTML deserialization can trigger browser behavior during parsing
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-88976.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@platejs/corenpmDescription
Summary
HTML strings passed to Plate's core deserialization APIs were parsed in the active document. Certain HTML attributes could therefore trigger browser behavior during parsing, before the content was converted into editor nodes.
Applications that deserialize HTML from untrusted or cross-user sources may be affected.
Impact
An attacker who can control HTML later deserialized in another user's browser may be able to execute script in that application's origin.
Remediation
Upgrade to @platejs/core 53.3.11 or later. Users of the discontinued 54.0.0 beta builds should install the fixed stable line. Applications should also sanitize untrusted HTML before rendering it; inert parsing is not a substitute for sanitization.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @platejs/core | all versions | 53.3.11npm install @platejs/core@53.3.11 |
| 📦npm | @platejs/core | ≥ 54.0.0-beta.0 | No fix |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @platejs/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @platejs/core to 53.3.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-88976 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2026-88976 in your dependencies?
Find it across npm, including transitive dependencies.