CVE-2026-88029 — pymongo
Fix: mongodb/mongo-python-driver#3046CVE-2026-88029 is a CWE-943 vulnerability in pymongo. A fix is available for pymongo — see the affected versions and patch details below.
GridFS data disclosure and deletion via query-operator injection in file IDs in the MongoDB Python Driver
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-88029.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
pymongoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Improper neutralization of special elements in data query logic in the GridFS component of the MongoDB Python Driver can cause a caller-supplied structured file identifier to be interpreted as a query condition rather than as a literal identifier. An authenticated user who can influence the identifier passed by an affected application may obtain stored file content beyond the intended target or cause all GridFS file chunks in the affected bucket to be removed, rendering stored file content unreadable. The affected rename operation may also rename a stored file other than the intended target.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | pymongo | all versions | 4.18.1pip install --upgrade 'pymongo==4.18.1' |
Affected Products
python drivermongodbDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pymongo, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update pymongo to 4.18.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-88029 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability is rated as Important because an authenticated user who can influence a GridFS file identifier can delete all file chunks in the affected bucket, making stored files unreadable, and can retrieve or rename a file other than the intended target. Exploitation requires an application to pass a…
There is no complete mitigation for applications that must accept untrusted structured GridFS file identifiers. The following measures reduce risk until a patched pymongo is available: 1. Pass only literal identifiers to GridFS download, delete, and rename operations (ObjectId, string, or integer). Do not pass dictionaries, BSON documents, or other structured values derived from user input. 2. Restrict which authenticated users can invoke GridFS operations, and do not expose GridFS APIs to untrusted clients. 3. If GridFS is not required, avoid using the gridfs module.Source: Red Hat security advisory for CVE-2026-88029 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 8 | python36:3.6-8100020261001091315.4c5117ad | RHSA-2026:82858 |
| Red Hat OpenShift AI 2.25 | rhoai/odh-llama-stack-core-rhel9:1791873747 | RHSA-2026:87410 |
| Red Hat OpenShift AI 3.4 | rhoai/odh-llama-stack-core-rhel9:1790958470 | RHSA-2026:84734 |
| Red Hat OpenShift AI 3.5 | rhoai/odh-ogx-core-rhel9:1790963109 | RHSA-2026:86891 |
Frequently Asked Questions
Is CVE-2026-88029 in your dependencies?
Find it across PyPI, including transitive dependencies.