CVE-2026-86079 — n8n
CVE-2026-86079 is a Path Traversal vulnerability in n8n. A fix is available for n8n — see the affected versions and patch details below.
n8n: Path Injection in Elasticsearch and ElasticSecurity Nodes via Unencoded Identifiers
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-86079.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
n8nnpmDescription
Impact
The Elasticsearch and ElasticSecurity nodes built REST endpoints by interpolating user-provided identifiers straight into the request path. A value containing path separators or dot segments changed which endpoint the request actually reached, so an operation intended for one document could hit another index or a cluster administration endpoint instead, under the stored Elasticsearch credential. The patch encodes each identifier as a single URL path segment and rejects values that normalise away.
Patches
The issue has been fixed in n8n versions 1.123.76, 2.37.7, and 2.38.2. Users should upgrade to one of these versions or later to remediate the vulnerability.
Workarounds
If upgrading is not immediately possible, administrators should consider the following temporary mitigations:
- Restrict n8n instance access to fully trusted users only.
- Disable the affected nodes by adding
n8n-nodes-base.elasticsearchandn8n-nodes-base.elasticSecurityto theNODES_EXCLUDEenvironment variable if they are not required. - Audit existing workflows that use these nodes and ensure that index and document identifier fields do not accept externally-controlled input.
These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | n8n | all versions | 1.123.76npm install n8n@1.123.76 |
| 📦npm | n8n | ≥ 2.38.0&&< 2.38.2 | 2.38.2npm install n8n@2.38.2 |
| 📦npm | n8n | ≥ 2.0.0&&< 2.37.7 | 2.37.7npm install n8n@2.37.7 |
Affected Products
n8nn8nDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for n8n, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update n8n to 1.123.76 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-86079 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2026-86079 in your dependencies?
Find it across npm, including transitive dependencies.