NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2026-77608 — semantic-media-wiki

MEDIUM

CVE-2026-77608 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in mediawiki/semantic-media-wiki. A fix is available for mediawiki/semantic-media-wiki — see the affected versions and patch details below.

Semantic MediaWiki has reflected XSS in `Special:SearchByProperty` (`property` and `value` parameters)

Also known asGHSA-59xw-qv23-j3rc
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-77608.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs21th percentile — riskier than 21% of all scored CVEsHighest risk
0.00%0.26%0.52%0.78%0.3%0.3%0.3%Oct 26Nov 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘mediawiki/semantic-media-wiki

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Failure mode

The value parameter was reflected back into rendered output and error messaging paths without enough output-context encoding.

Remediation

  • The form value is escaped before it is placed back into the input field.
  • Derived error messages are also escaped before being rendered into HTML.

Maintenance note

Do not treat error text as trusted just because it originated from validation. Validation output can still be attacker-influenced.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmediawiki/semantic-media-wikiall versions7.2.0composer require mediawiki/semantic-media-wiki:^7.2.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mediawiki/semantic-media-wiki, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mediawiki/semantic-media-wiki to 7.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-77608 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

#### Failure mode The `value` parameter was reflected back into rendered output and error messaging paths without enough output-context encoding. #### Remediation - The form value is escaped before it is placed back into the input field. - Derived error messages are also escaped before being rendered into HTML. #### Maintenance note Do not treat error text as trusted just because it originated from validation. Validation output can still be attacker-influenced.
O3 Security · Impact-Aware SCA

Is CVE-2026-77608 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2026-77608: semantic-media-wiki — Fixed in 7.2.0