CVE-2026-70611 is a medium-severity (CVSS 6.9) OS Command Injection vulnerability in electron. A fix is available for electron — see the affected versions and patch details below.
Electron: DevTools embedder handler executes arbitrary files via shell open
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-70611.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
electronnpmDescription
Impact
The DevTools "reveal in file manager" action could launch the target file rather than reveal it. An attacker with a separate means of running script inside the DevTools frontend (such as a malicious DevTools extension) could use this to execute native code outside the sandbox.
Apps are only affected if DevTools is opened for windows exposed to untrusted content or untrusted DevTools extensions. Apps that do not open DevTools in that context are not affected.
Workarounds
Do not open DevTools for windows that load untrusted content, and do not load untrusted DevTools extensions.
Fixed Versions
42.0.0-beta.341.2.140.9.239.8.9
For more information
If you have any questions or comments about this advisory, email Electron at [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | electron | all versions | 39.8.9npm install electron@39.8.9 |
| 📦npm | electron | ≥ 40.0.0-alpha.1&&< 40.9.2 | 40.9.2npm install electron@40.9.2 |
| 📦npm | electron | ≥ 41.0.0-alpha.1&&< 41.2.1 | 41.2.1npm install electron@41.2.1 |
| 📦npm | electron | ≥ 42.0.0-alpha.1&&< 42.0.0-beta.3 | 42.0.0-beta.3npm install electron@42.0.0-beta.3 |
Affected Products
electronelectronjsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for electron, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update electron to 39.8.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-70611 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2026-70611 in your dependencies?
Find it across npm, including transitive dependencies.