CVE-2026-70604 — electron
HIGHCVE-2026-70604 is a high-severity (CVSS 7.4) CWE-942 vulnerability in electron. A fix is available for electron — see the affected versions and patch details below.
Electron: Custom protocol with supportFetchAPI but not corsEnabled allows cross-origin reads
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-70604.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
electronnpmDescription
Impact
A custom scheme registered with supportFetchAPI: true but without corsEnabled: true was not subject to CORS enforcement. A page loaded from a remote origin could therefore fetch() or XMLHttpRequest that scheme cross-origin and read the full response body, rather than the read being blocked.
Apps that serve sensitive data from such a scheme and load remote or untrusted content in a renderer are affected. Apps that set corsEnabled: true, or that do not load untrusted content, are not affected.
Workarounds
Set corsEnabled: true on schemes that must enforce CORS, and validate the request Origin in your protocol handler before returning sensitive data.
Fixed Versions
42.0.041.4.040.9.339.8.10
For more information
If you have any questions or comments about this advisory, email Electron at [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | electron | ≥ 42.0.0-alpha.1&&< 42.0.0 | 42.0.0npm install electron@42.0.0 |
| 📦npm | electron | ≥ 41.0.0-alpha.1&&< 41.4.0 | 41.4.0npm install electron@41.4.0 |
| 📦npm | electron | ≥ 40.0.0-alpha.1&&< 40.9.3 | 40.9.3npm install electron@40.9.3 |
| 📦npm | electron | all versions | 39.8.10npm install electron@39.8.10 |
Affected Products
electronelectronjsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for electron, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update electron to 42.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-70604 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2026-70604 in your dependencies?
Find it across npm, including transitive dependencies.