CVE-2026-70602 — electron
MEDIUMCVE-2026-70602 is a medium-severity (CVSS 6.6) CWE-284 vulnerability in electron. A fix is available for electron — see the affected versions and patch details below.
Electron: Extension tab APIs operate across session boundaries
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-70602.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
electronnpmDescription
Impact
Extension tab and scripting APIs were not scoped to the extension's own session. A malicious or compromised extension loaded into one session could navigate, script, and read from windows belonging to a different session.
Apps are only affected if they load Chrome extensions via session.loadExtension and rely on separate sessions to isolate that extension from other content. Apps that do not load extensions, or that use a single session, are not affected.
Workarounds
Only load extensions from sources you trust; do not rely on session separation alone to contain an extension.
Fixed Versions
42.0.0-beta.341.2.140.9.039.8.8
For more information
If you have any questions or comments about this advisory, email Electron at [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | electron | all versions | 39.8.8npm install electron@39.8.8 |
| 📦npm | electron | ≥ 40.0.0-alpha.1&&< 40.9.0 | 40.9.0npm install electron@40.9.0 |
| 📦npm | electron | ≥ 41.0.0-alpha.1&&< 41.2.1 | 41.2.1npm install electron@41.2.1 |
| 📦npm | electron | ≥ 42.0.0-alpha.1&&< 42.0.0-beta.3 | 42.0.0-beta.3npm install electron@42.0.0-beta.3 |
Affected Products
electronelectronjsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for electron, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update electron to 39.8.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-70602 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2026-70602 in your dependencies?
Find it across npm, including transitive dependencies.