CVE-2026-69243 — aiohttp
Fix: aio-libs/aiohttp@6ae358fCVE-2026-69243 is a CWE-444 vulnerability in aiohttp. A fix is available for aiohttp — see the affected versions and patch details below.
AIOHTTP: HTTP request smuggling via WebSocket upgrade
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-69243.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
aiohttpReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
AIOHTTP is an asynchronous HTTP client/server framework for asyncio and Python. Prior to 3.14.2, the HTTP parsers were vulnerable to a request smuggling attack relating to WebSocket upgrades. If using the server-side component, an attacker may be able to execute a request smuggling vulnerability using an edge case in the WebSocket upgrade procedure. A WebSocket upgrade request with a body could cause the parser to switch protocols before the complete request body was received, leaving trailing bytes to be handled as upgraded-protocol or pipelined data rather than normal HTTP body data. This issue is fixed in version 3.14.2.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | aiohttp | all versions | 3.14.2pip install --upgrade 'aiohttp==3.14.2' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for aiohttp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update aiohttp to 3.14.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-69243 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Moderate impact. This vulnerability in aiohttp's HTTP parser enables request smuggling when the server-side component handles WebSocket upgrade requests containing a body. An attacker could exploit an edge case during protocol switching, causing trailing data to be processed as subsequent requests or upgraded protocol…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Ansible Automation Platform 2.5 for RHEL 8 | python3.12-aiohttp-0:3.14.3-1.el8ap | RHSA-2026:59135 |
| Red Hat Ansible Automation Platform 2.6 for RHEL 9 | automation-controller-0:4.7.16-1.el9ap | RHSA-2026:59136 |
| Red Hat Satellite 6.16 for RHEL 8 | python-aiohttp-0:3.14.3-1.el8pc | RHSA-2026:63327 |
| Red Hat Satellite 6.17 for RHEL 9 | ansible-core-1:2.16.19-1.el9sat | RHSA-2026:63387 |
| Red Hat Satellite 6.18 for RHEL 9 | pulpcore-obsolete-packages-0:1.3.1-5.el9pc | RHSA-2026:63386 |
| Red Hat Satellite 6.19 for RHEL 9 | python3.12-aiohttp-0:3.14.3-1.el9pc | RHSA-2026:63385 |
| Red Hat AI Inference Server 3.2 | rhaiis/model-opt-cuda-rhel9:1790621714 | RHSA-2026:73859 |
| Red Hat AI Inference Server 3.2 | rhaiis/vllm-cuda-rhel9:1790621718 | RHSA-2026:73929 |
Frequently Asked Questions
Is CVE-2026-69243 in your dependencies?
Find it across PyPI, including transitive dependencies.