CVE-2026-68537 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in fulgur. A fix is available for fulgur — see the affected versions and patch details below.
Fulgur: Unbounded page slicing from attacker-controlled CSS height causes denial of service
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-68537.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
fulgurReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
fulgur converts untrusted HTML/CSS into PDF, commonly on a server that
processes input supplied by many tenants. In versions prior to 0.26.0, a
childless box that resolves to a pathologically tall height was amplified into
thousands of blank PDF pages, even when it produces no visible output.
The childless-collapse defense that would normally collapse such a box was gated by a tag-only "replaced content" check, so any non-painting replaced element bypassed it, including:
- an unresolved
src(the common offline-first case), - a
visibility:hiddenimage, - an undecodable image format, and
- an empty
<svg>.
A trailing-sibling variant of the same gap was also open. A few bytes of HTML
therefore amplified into roughly MAX_PAGES (10,000) blank pages; the renderer
allocates and runs a per-page loop over them, producing CPU and memory
exhaustion. An attacker able to submit HTML to a fulgur-based conversion service
can trigger this with a trivially small payload, denying service to the host and
any co-tenants.
Patches
Fixed in 0.26.0 (PR #575). The tag-only gate was removed so that any
pathologically tall childless box collapses regardless of whether it is a
replaced element, closing the missing-src, visibility:hidden,
undecodable-format, and empty-<svg> vectors at once, along with the
trailing-sibling variant.
Workarounds
Upgrade to 0.26.0 or later. If upgrading is not immediately possible, validate
or constrain untrusted CSS (in particular very large height / vh on
elements) before passing HTML to fulgur.
Related
Versions prior to 0.19.0 additionally lacked any page-count cap, allowing an unbounded (rather than 10,000-page) variant of this amplification and a non-terminating loop on non-finite heights. That earlier variant is tracked separately as GHSA-j5cx-ph8g-95v3.
Attack Vector rationale
fulgur performs no network I/O of its own; it renders HTML/CSS handed to it by
the embedding application. This advisory scores the crate independent of any
specific adopting program, so per the CVSS v3.1 User Guide §3.7 (scoring library
vulnerabilities related to incoming data) the Attack Vector is assessed as
Network for the reasonable worst-case deployment — a network-facing service
that renders untrusted, attacker-supplied HTML without user interaction. A
concrete system that receives the HTML in one component and passes it to fulgur
in a separate component may assess a lower environmental Attack Vector (Local,
per §3.10).
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | fulgur | all versions | 0.26.0cargo update -p fulgur --precise 0.26.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for fulgur, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update fulgur to 0.26.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-68537 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2026-68537 in your dependencies?
Find it across crates.io, including transitive dependencies.