NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2026-66274 — proton-j

HIGHFix: apache/qpid-proton-j@9204741

CVE-2026-66274 is a high-severity (CVSS 7.5) CWE-674 vulnerability in org.apache.qpid:proton-j. A fix is available for org.apache.qpid:proton-j — see the affected versions and patch details below.

Apache Qpid Proton-J: Unbounded type nesting can lead to pre-authentication stackoverflow

Also known asGHSA-p2gc-fm5w-94jj
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs56th percentile — riskier than 56% of all scored CVEsHighest risk
0.00%0.42%0.85%1.27%0.5%0.8%0.8%Sep 26Oct 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.qpid:proton-j

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service.

This issue affects Apache Qpid Proton-J: through 0.34.1.

Users are recommended to upgrade to version 0.35.0, which fixes the issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.qpid:proton-jall versions0.35.0org.apache.qpid:proton-j:0.35.0

Affected Products

1 product · 1 configurations
Application
qpid proton-japache
< 0.35.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.qpid:proton-j, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.qpid:proton-j to 0.35.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-66274 is resolved across your whole dependency graph.

  3. Workarounds

    Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

This vulnerability is rated as Important as a remote, unauthenticated attacker can trigger a denial of service in Apache Qpid Proton-J. By sending specially crafted messages with unbounded type nesting, an attacker can cause a StackOverflowError, leading to service unavailability without requiring prior authentication…

Workaround published by Red Hat
To mitigate this issue, restrict network access to services utilizing Apache Qpid Proton-J to trusted clients and networks only. Implement firewall rules to limit inbound connections to the specific ports used by these services. This operational control reduces the attack surface by preventing untrusted external access, but may impact legitimate client connectivity if not carefully configured.
Source: Red Hat security advisory for CVE-2026-66274 (CC BY 4.0)
ProductFixed inAdvisory
AMQ Clients 2026.Q3proton-jRHSA-2026:69459
Red Hat AMQ Broker 7.13.6amq-broker-bin.zipRHSA-2026:66545
Red Hat AMQ Broker 7.14.1amq-broker-bin.zipRHSA-2026:66488
Red Hat Build of Apache Camel 3.33.3.SP1org.apache.qpid/proton-j:0.35.0.redhat-00001RHSA-2026:63302
Red Hat build of Apache Camel 4.18.4 for Spring Boot 3.5.16rhaf-camel-for-springboot-maven-repository.zipRHSA-2026:71675
Red Hat build of Quarkus 3.27.5.SP1org.apache.qpid/proton-j:0.35.0.redhat-00001RHSA-2026:62515
Red Hat build of Quarkus 3.33.3.SP1org.apache.qpid/proton-j:0.35.0.redhat-00001RHSA-2026:62555
Red Hat JBoss Enterprise Application Platform 8.1proton-jRHSA-2026:95221

Frequently Asked Questions

A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service. This issue affects Apache Qpid Proton-J: through 0.34.1. Users are recommended to upgrade to version 0.35.0, which fixes the issue.
O3 Security · Impact-Aware SCA

Is CVE-2026-66274 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2026-66274: proton-j DoS — Fixed in 0.35.0