CVE-2026-59267 — Apache Openoffice
HIGHCVE-2026-59267 is a high-severity (CVSS 7.8) CWE-122 vulnerability in apache openoffice. A fix is available — see the affected versions and patch details below.
A crafted DXF document causes a heap buffer overflow in Draw in Apache OpenOffice 4.1.16 and earlier. This could cause a crash or otherwise a corruption of memory areas. Users are recommended…
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-59267.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Description
A crafted DXF document causes a heap buffer overflow in Draw in Apache OpenOffice 4.1.16 and earlier. This could cause a crash or otherwise a corruption of memory areas. Users are recommended to upgrade to version 4.1.17, which fixes this issue.
Affected Products
openofficeapacheDetection & mitigation playbook
Vendor / applianceDetect
Inventory every apache openoffice deployment and check each version against the affected-products list above.
Fix
Apply the apache openoffice security patch or hotfix for CVE-2026-59267 on the affected version, following the vendor advisory for your exact build.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable. Alongside that, restrict the management interface to trusted networks and apply the vendor's recommended configuration mitigations.
Frequently Asked Questions
Is CVE-2026-59267 being exploited in your environment?
Detect and block the exploit chain at execution, on systems you cannot patch yet.