CVE-2026-56846 — node
CVE-2026-56846 is a Uncontrolled Resource Consumption vulnerability in node. A fix is available for node — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-56846.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
nodeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Bitnami packages — download data is not available via public APIs for these ecosystems.
Description
A flaw in Node.js HTTP/2 handling can cause HTTP/2 retained header blocks evade maxSessionMemory and enable remote memory exhaustion.
This vulnerability affects Node.js 24.x and 22.x.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦Bitnami | node | ≥ 23.0.0&&< 22.23.2 | 22.23.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for node, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update node to 22.23.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-56846 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This Important flaw in Node.js HTTP/2 handling allows a remote attacker to bypass `maxSessionMemory` limits by sending specially crafted header blocks. This can lead to memory exhaustion and a denial of service for Node.js applications configured to use HTTP/2, without requiring authentication or user interaction.
To mitigate this issue, restrict network access to Node.js applications utilizing HTTP/2 to trusted clients only, by implementing firewall rules or network access controls. If HTTP/2 functionality is not essential for the application, consider disabling it in the Node.js configuration to prevent exploitation. Always ensure that any service restarts or reloads are performed carefully to avoid service disruption.Source: Red Hat security advisory for CVE-2026-56846 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 10 | nodejs22-1:22.23.2-1.el10_2 | RHSA-2026:61376 |
| Red Hat Enterprise Linux 10 | nodejs24-1:24.19.0-1.el10_2 | RHSA-2026:61377 |
| Red Hat Enterprise Linux 10.0 Extended Update Support | nodejs22-1:22.23.2-1.el10_0 | RHSA-2026:64817 |
| Red Hat Enterprise Linux 8 | nodejs:22-8100020260819113925.6d880403 | RHSA-2026:62219 |
| Red Hat Enterprise Linux 8 | nodejs:24-8100020260819113942.6d880403 | RHSA-2026:62583 |
| Red Hat Enterprise Linux 9 | nodejs:22-9080020260819113937.rhel9 | RHSA-2026:61383 |
| Red Hat Enterprise Linux 9 | nodejs:24-9080020260819113946.rhel9 | RHSA-2026:61386 |
| Red Hat Enterprise Linux 9.6 Extended Update Support | nodejs:22-9060020260901085634.rhel9 | RHSA-2026:62416 |
Frequently Asked Questions
Is CVE-2026-56846 in your dependencies?
Find it across Bitnami, including transitive dependencies.