NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

CVE-2026-56778 — n8n

CVE-2026-56778 is a CWE-863 vulnerability in n8n. A fix is available for n8n — see the affected versions and patch details below.

n8n - Authorization Bypass in Public API Execution Retry Endpoint

Also known asGHSA-h3jj-5f3v-3685
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-56778.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs22th percentile — riskier than 22% of all scored CVEsHighest risk
0.00%0.27%0.53%0.80%0.2%0.3%0.3%0.3%Aug 26Oct 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

36other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
n8nnpm
152Kdownloads / week

Description

Impact

The Public API endpoint for retrying executions authorized access using workflow:read rather than workflow:execute. An authenticated user with read-only access to a shared workflow could use the Public API to retry executions of that workflow, bypassing the intended permission boundary between read and execute access.

This issue affects instances where workflows are shared with other users or across projects.

Patches

The issue has been fixed in n8n versions 2.25.7, and 2.26.2. Users should upgrade to one of these versions or later to remediate the vulnerability.

Workarounds

If upgrading is not immediately possible, administrators should consider the following temporary mitigations:

  • Restrict workflow sharing to fully trusted users only.
  • Restrict network access to the n8n Public API to trusted users only.

These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmn8n≥ 2.26.0&&< 2.26.22.26.2npm install n8n@2.26.2
📦npmn8nall versions2.25.7npm install n8n@2.25.7

Affected Products

1 product · 2 configurations
Application
n8nn8n
≥ 2.26.0 && < 2.26.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for n8n, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update n8n to 2.26.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-56778 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

## Impact The Public API endpoint for retrying executions authorized access using `workflow:read` rather than `workflow:execute`. An authenticated user with read-only access to a shared workflow could use the Public API to retry executions of that workflow, bypassing the intended permission boundary between read and execute access. This issue affects instances where workflows are shared with other users or across projects. ## Patches The issue has been fixed in n8n versions 2.25.7, and 2.26.2. Users should upgrade to one of these versions or later to remediate the vulnerability. ## Workarou
O3 Security · Impact-Aware SCA

Is CVE-2026-56778 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-56778: n8n — Fixed in 2.26.2