CVE-2026-4810 — google-adk
CVE-2026-4810 is a Missing Authentication vulnerability in google-adk. A fix is available for google-adk — see the affected versions and patch details below.
Google Agent Development Kit (ADK) has a Code Injection and Missing Authentication vulnerability
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-4810.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
google-adk🐍google-adkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
A Code Injection and Missing Authentication vulnerability in Google Agent Development Kit (ADK) versions 1.7.0 (and 2.0.0a1) through 1.28.1 (and 2.0.0a2) on Python (OSS), Cloud Run, and GKE allows an unauthenticated remote attacker to execute arbitrary code on the server hosting the ADK instance.
This vulnerability was patched in versions 1.28.1 and 2.0.0a2.
Customers need to redeploy the upgraded ADK to their production environments. In addition, if they are running ADK Web locally, they also need to upgrade their local instance.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | google-adk | ≥ 1.7.0&&< 1.28.1 | 1.28.1pip install --upgrade 'google-adk==1.28.1' |
| 🐍PyPI | google-adk | ≥ 2.0.0a1&&< 2.0.0a2 | 2.0.0a2pip install --upgrade 'google-adk==2.0.0a2' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for google-adk, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update google-adk to 1.28.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-4810 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
How to detect CVE-2026-4810
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2026-4810 -u https://target- Template
- Google ADK-Python - Unauthenticated Builder Endpoint
- Severity
- critical
- Impact
- Unauthenticated remote attackers can execute arbitrary code on the server, leading to full system compromise.
- Remediation
- Upgrade to versions 1.28.1 and 2.0.0a2 or later and redeploy to production and local environments.
Template by ProjectDiscovery nuclei-templates (dwisiswant0), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2026-4810 in your dependencies?
Find it across PyPI, including transitive dependencies.