CVE-2026-44992 — openclaw
Fix: openclaw/openclaw@2f06696CVE-2026-44992 is a CWE-441 vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.
OpenClaw 2026.4.5 through 2026.4.19 - MiniMax API Host Override via Workspace dotenv
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-44992.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
openclawnpmDescription
Affected Packages / Versions
- Package:
openclaw(npm) - Affected versions:
>= 2026.4.5, < 2026.4.20 - Patched version:
2026.4.20
Impact
A malicious workspace .env could set MINIMAX_API_HOST and redirect credentialed MiniMax requests to an attacker-controlled origin, exposing the MiniMax API key in the outbound Authorization header.
This requires running OpenClaw from an attacker-controlled workspace. Severity is medium.
Fix
OpenClaw now blocks MINIMAX_API_HOST from workspace dotenv injection and removes env-driven URL routing from the affected MiniMax request path.
Fix commit:
2f06696579a1ab0cb5bbbbb6a900414a6b2e3cd1
Release
Fixed in OpenClaw 2026.4.20.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | openclaw | ≥ 2026.4.5&&< 2026.4.20 | 2026.4.20npm install openclaw@2026.4.20 |
Affected Products
openclawopenclawDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update openclaw to 2026.4.20 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-44992 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2026-44992 in your dependencies?
Find it across npm, including transitive dependencies.