CVE-2026-44913 — nifi-cdc-mysql-processors
Fix: apache/nifi#11206CVE-2026-44913 is a CWE-116 vulnerability in org.apache.nifi:nifi-cdc-mysql-processors. A fix is available for org.apache.nifi:nifi-cdc-mysql-processors — see the affected versions and patch details below.
Apache NiFi: Improper Escaping of Table Names in CaptureChangeMySQL
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-44913.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.nifi:nifi-cdc-mysql-processorsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Improper escaping of database table names in the CaptureChangeMySQL Processor included with Apache NiFi 1.2.0 through 2.9.0 allows for injecting SQL commands using crafted naming. Manual quoted boundaries added in Apache NiFi 1.8.0 narrowed the scope of potential injection options, but did not cover additional strategies. Apache NiFi installations that do not use the CaptureChangeMySQL Processor are not subject to this vulnerability. Upgrading to Apache NiFi 2.10.0 is the recommended mitigation, which incorporates more robust identifier escaping.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.nifi:nifi-cdc-mysql-processors | ≥ 1.2.0&&< 2.10.0 | 2.10.0org.apache.nifi:nifi-cdc-mysql-processors:2.10.0 |
Affected Products
nifiapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.nifi:nifi-cdc-mysql-processors, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.nifi:nifi-cdc-mysql-processors to 2.10.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-44913 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2026-44913 in your dependencies?
Find it across Maven, including transitive dependencies.