NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2026-44262 — scramble

CRITICAL

CVE-2026-44262 is a critical-severity (CVSS 9.4) Code Injection vulnerability in dedoc/scramble. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for dedoc/scramble — see the affected versions and patch details below.

Scramble: Remote code execution via evaluation of user-controlled input in validation rules

Also known asGHSA-4rm2-28vj-fj39
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-44262.

EPSS Exploitation Probability

via FIRST.org ↗
5.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs93th percentile — riskier than 93% of all scored CVEsHighest risk
0.00%2.47%4.93%7.40%0.7%5.9%Jun 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘dedoc/scramble

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

A remote code execution (RCE) vulnerability affects versions 0.13.2 through 0.13.21. When documentation endpoints are publicly accessible and validation rules reference user-controlled input, request supplied data may be evaluated during documentation generation, leading to execution of arbitrary PHP code in the application context.

Patches

Fixed in version 0.13.22.

Workarounds

If upgrading is not immediately possible:

  • Restrict access to documentation endpoints (/docs/api, /docs/api.json)
  • Avoid using user-controlled variables inside validation rule expressions (e.g., values derived from request input)
  • Disable documentation endpoints in production environments if not required

These measures significantly reduce or prevent exploitability.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdedoc/scramble≥ 0.13.2&&< 0.13.220.13.22composer require dedoc/scramble:^0.13.22
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-52582webappsphp

scramble - Remote Code Execution

by joshua · May 27, 2026

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for dedoc/scramble, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update dedoc/scramble to 0.13.22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-44262 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

How to detect CVE-2026-44262

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2026-44262 -u https://target
Template
Scramble Laravel - Remote Code Execution
Severity
critical
Impact
Remote attackers can execute arbitrary PHP code, potentially leading to full application compromise.
Remediation
Upgrade to version 0.13.22 or later.

Template by ProjectDiscovery nuclei-templates (joshuavanderpoll), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

### Impact A remote code execution (RCE) vulnerability affects versions `0.13.2` through `0.13.21`. When documentation endpoints are publicly accessible and validation rules reference user-controlled input, request supplied data may be evaluated during documentation generation, leading to execution of arbitrary PHP code in the application context. ### Patches Fixed in version `0.13.22`. ### Workarounds If upgrading is not immediately possible: * Restrict access to documentation endpoints (`/docs/api`, `/docs/api.json`) * Avoid using user-controlled variables inside validation rule expres
O3 Security · Impact-Aware SCA

Is CVE-2026-44262 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2026-44262: scramble RCE — Fixed in 0.13.22